O Coppermine por ser uma ferramenta OpenSource (Código Aberto ou Código Livre), permite a instalação de plugins, que são recursos extras que implementam ainda mais o sistema.

Para ver os plugins disponíveis para instalação, basta acessar Configurar > Gerenciar Plugins. Note que a maioria deles, por padrão, encontra-se “Desinstalados”.

Para instalar um plugin, devemos clicar no ícone do pacotinho com uma seta para cima, conforme imagem:

No exemplo, iremos habilitar o plugin Quem está online? (onlinestats): v2.6, que exibe um bloco em cada galeria mostrando os usuários que encontram-se Online.

Você deverá determinar o tempo para que cada usuário apareça na lista. Clique em Ok.

Note que a partir de agora este plugin fica disponível na área de plugins instalados. Caso você queira novamente acessar as configurações individuais do plugin, clique no botão “Configure Plugin”.

Para conferir o plugin em ação, vá para a home da galeria e desça até a parte inferior/rodapé da página e confira o bloco:

É possível ainda efetuar a instalação manual dos plugins. Para isso, volte novamente na opção Configurar > Gerenciar plugins .

Procure pelo campo de envio de arquivos:

Agora, acesse o site oficial do Coppermine http://coppermine-gallery.net/ e clique em Plugins ou acesse diretamente este link: http://coppermine-gallery.net/plugins.php?cpg_version=both

OBS1: É importante frisar que para o bom funcionamento do plugin e de seus recursos é indicado que instale plugins disponíveis para a versão do Coppermine que você está usando.

OBS2: Alguns plugins não possuem tradução para o português brasileiro.

Para saber a versão do seu Coppermine instalado, acesse o administrador com um usuário admin e no menu superior clique em “Configurar”.

Na listagem, escolha os plugins que desejar e clique no ícone para baixá-lo:

Logo no cabeçalho da opção será possível ver a versão atual do sistema, no nosso exemplo 1.5.20.

Lá na página de download de plugins do site Coppermine é possível filtar a listagem de plugins, selecionando apenas os plugins disponíveis para a versão que desejar, ou seja, 1.4.x que serve para todas as versões e atualizações do 1.4 e 1.5.x que serve para todas as versões e atualizações da versão 1.5.

Páginas Relacionadas